Server startet nicht

Diskussionen rund um den SVWS-Server

Moderatoren: A. Schüller, Raffenberg, Pfotenhauer

Antworten
Benutzeravatar
wschrewe
Fachberater*in
Beiträge: 1979
Registriert: Dienstag 25. September 2018, 17:36
Schulform: BK (Pensionär)
Kontaktdaten:

Server startet nicht

Beitrag von wschrewe »

Der SVWS-Server startet nicht mehr bzw. wird sofort nach dem Start wieder beendet. Hat jemand eine Ahnung, woran das liegt? Mein Verdacht ist, dass das dienstägliche Windows-Update damit zu tun hat. Kann das sein?
Mit freundlichen Grüßen
Walter Schrewe
"If all else fails, read the instructions" (Donald E. Knuth, letzter TeX - Hilfehinweis)
Raffenberg
Beiträge: 3250
Registriert: Dienstag 25. September 2018, 15:22
Schulform: Gymnasium
Kontaktdaten:

Re: Server startet nicht

Beitrag von Raffenberg »

Hallo Herr Schrewe,
läuft der Dienst nicht, oder kann Schild3 keine Verbindung aufbauen?
Mit freundlichen Grüßen
Jens Raffenberg
Benutzeravatar
wschrewe
Fachberater*in
Beiträge: 1979
Registriert: Dienstag 25. September 2018, 17:36
Schulform: BK (Pensionär)
Kontaktdaten:

Re: Server startet nicht

Beitrag von wschrewe »

Raffenberg hat geschrieben: Samstag 16. März 2024, 11:08läuft der Dienst nicht,
Der Dienst läuft nicht. Wenn ich ihn manuell starte, wird er nach kurzer Zeit, von wem auch immer, wieder gestoppt. Der Dienst für die MariaDB läuft einwandfrei.
Mit freundlichen Grüßen
Walter Schrewe
"If all else fails, read the instructions" (Donald E. Knuth, letzter TeX - Hilfehinweis)
Raffenberg
Beiträge: 3250
Registriert: Dienstag 25. September 2018, 15:22
Schulform: Gymnasium
Kontaktdaten:

Re: Server startet nicht

Beitrag von Raffenberg »

Mhh. Bei mir läuft soweit alles (Windows 11 - 23H2). Ein Antivirenscanner würde ja Meldung geben. Liefert die Ereignisanzeige Hinweise (unter Ereignisanzeige - Windows Protokolle - Anwendungen)?
Mit freundlichen Grüßen
Jens Raffenberg
A. Schüller
Beiträge: 1175
Registriert: Mittwoch 10. Februar 2021, 21:30
Schulform: Gymnasium

Re: Server startet nicht

Beitrag von A. Schüller »

Wird der Dienst nach dem Startversuch von SchILD3 gestoppt oder willkürlich nach einer gewissen Zeit?
Gibt es Hinweise im Log-File?:svws_server_service.out.log
Mit freundlichen Grüßen
Anne Schüller
Benutzeravatar
wschrewe
Fachberater*in
Beiträge: 1979
Registriert: Dienstag 25. September 2018, 17:36
Schulform: BK (Pensionär)
Kontaktdaten:

Re: Server startet nicht

Beitrag von wschrewe »

Fehler gefunden und beseitigt. In der svwsconfig.json gab es (nachdem ich eine weitere DB migriert hatte) einen fehlerhaften Eintrag. Der Hinweis auf die Log-Dateien war sehr hilfreich.
Mit freundlichen Grüßen
Walter Schrewe
"If all else fails, read the instructions" (Donald E. Knuth, letzter TeX - Hilfehinweis)
Benutzeravatar
wschrewe
Fachberater*in
Beiträge: 1979
Registriert: Dienstag 25. September 2018, 17:36
Schulform: BK (Pensionär)
Kontaktdaten:

Re: Server startet nicht

Beitrag von wschrewe »

Das Problem wurde ja, wie gesagt, durch einen fehlerhaften Eintrag in der Konfigurationsdatei verursacht. Aus meiner Sicht wäre es anwenderfreundlicher, wenn hier eine aussagekräftige Fehlermeldung erfolgen würde. Dass der Server in so einem Fall ohne weitere Rückmeldung insgesamt den Dienst quittiert, ist (für mich) doch etwas überraschend.
Mit freundlichen Grüßen
Walter Schrewe
"If all else fails, read the instructions" (Donald E. Knuth, letzter TeX - Hilfehinweis)
Raffenberg
Beiträge: 3250
Registriert: Dienstag 25. September 2018, 15:22
Schulform: Gymnasium
Kontaktdaten:

Re: Server startet nicht

Beitrag von Raffenberg »

Hallo Herr Schrewe. Ich leite die Idee an das Programmierteam weiter.
Mit freundlichen Grüßen
Jens Raffenberg
HvdB
Beiträge: 140
Registriert: Donnerstag 10. Januar 2019, 13:35
Wohnort: Ruppichteroth
Schulform: Gesamtschule
Motto: Nur der BVB!

Re: Server startet nicht

Beitrag von HvdB »

Hallo zusammen!

Habe am Wochenende zum Testen auf unserem Schulserver den SVWS Server installiert, der Dienst will aber nicht starten. Die Migration der Datenbank ist durchgelaufen, aber in den Logs des Dienstes ist folgende Fehlermeldung zu finden:

Fehler beim Starten des Servers. Failed to bind to 0.0.0.0/0.0.0.0:443 SVWS Server wurde normal beendet.

Konkurrieren hier Dienste?

Schöne Grüße!

Hendryk von der Burg

@edit: Problem beim Formulieren der Nachricht erkannt und gelöst. Auf dem Server (MS Win 2022) lief der IIS Dienst. Erst nach Beenden des Dienstes startet auch der SVWS Server Dienst.
1909
1909
1909
1909
1909
1909
Frodermann
Fachberater*in
Beiträge: 1165
Registriert: Montag 29. Oktober 2018, 20:45
Schulform: Gesamtschule
Motto: Keine Panik

Re: Server startet nicht

Beitrag von Frodermann »

Port 443 ist ja der HTTPS-Port, das dürfte erstmal mit dem SVWS-Server als solchem nichts zu tun haben. Der Webclient greift über den Browser über https auf ihn zu, das dürfte hier ein Problem erzeugen?

0.0.0.0 ist eine IP-Adresse - aber eine, die nicht per Routing erreicht werden kann. Sie wird verwendet, um Host-Konflikte usw. zu erkennen.

Die MariaDB selbst läuft standardmäßig auf Port 3306.

Wenn der Port 443 irgendwie blockiert ist, könnte das an einer Firewall oder so liegen? Sind Sie auf einem Linux unterwegs? Dann könnte das hier helfen? Eventuell läuft da ein anderer Docker-Container?

https://serverfault.com/questions/61011 ... 0-0-0-0443

Abschluss des Posts: Jetzt erst den Edit-Vermerk gesehen. Diese Antwort ist nicht mehr notwendig, aber da wohl mit dem Problem verwandt, schicke ich Sie dennoch ab.
mit freundlichen Grüßen
Felix Frodermann
Fachberatung, Moderation & SVWS-Dokumentation - Korrekturen oder Wünsche bezüglich des Wikis und der SVWS-Webclient-Doku können Sie mir gerne über die hier im Forum hinterlegte Emailadresse zukommen lassen.
Antworten

Zurück zu „SVWS-Server“