Fehler (?) mit .lck-Dateien und Formularexplorer

Alles, was zu Kurs42 passt

Moderator: wschrewe

dkohle
Beiträge: 22
Registriert: Donnerstag 10. Januar 2019, 12:25
Schulform: Gymnasium

Fehler (?) mit .lck-Dateien und Formularexplorer

Beitrag von dkohle » Freitag 10. Januar 2020, 10:06

Hallo zusammen,
ich beobachte in der neuesten Kurs-Version (3.23.6.332), dass die .lck-Dateien beim Beenden des Programms nicht mehr gelöscht werden. Ist das Absicht?

Außerdem ist bei mir der Formularexplorer nach dem XML-Klausurimport nicht verwendbar, bis man Kurs neu startet. Kann das jemand bestätigen?

Beste Grüße,
D. Kohle

Benutzeravatar
wschrewe
Fachberater
Beiträge: 325
Registriert: Dienstag 25. September 2018, 17:36
Schulform: BK (Pensionär)
Kontaktdaten:

Re: Fehler (?) mit .lck-Dateien und Formularexplorer

Beitrag von wschrewe » Samstag 11. Januar 2020, 15:32

dkohle hat geschrieben:
Freitag 10. Januar 2020, 10:06
Kann das jemand bestätigen?
Ich nicht.
Mit freundlichen Grüßen
Walter Schrewe
"If all else fails, read the instructions" (Donald E. Knuth, letzter TeX - Hilfehinweis)

NielsWestphal
Beiträge: 233
Registriert: Sonntag 2. Dezember 2018, 18:33
Schulform: Gymnasium

Re: Fehler (?) mit .lck-Dateien und Formularexplorer

Beitrag von NielsWestphal » Samstag 11. Januar 2020, 16:28

Ich schon.
Das Löschen der lck-Datei sollte beim Schließen automatisch geschehen. Und eine Deaktivierung der Funktion in den Einstellungen macht auf dem lokalen PC ja Sinn, aber nicht, wenn die Datei im Netzwerk liegt und theoretisch an mehreren Rechnern gleichzeitig geöffnet werden kann.
mfg
Niels Westphal

dkohle
Beiträge: 22
Registriert: Donnerstag 10. Januar 2019, 12:25
Schulform: Gymnasium

Re: Fehler (?) mit .lck-Dateien und Formularexplorer

Beitrag von dkohle » Samstag 11. Januar 2020, 21:08

wschrewe hat geschrieben:
Samstag 11. Januar 2020, 15:32
dkohle hat geschrieben:
Freitag 10. Januar 2020, 10:06
Kann das jemand bestätigen?
Ich nicht.
Ich sollte präzisieren: Ich kann die Klausurreports nach dem XML-Import nicht starten. Es kommt eine Fehlermeldung. Nach einem Neustart von Kurs geht alles problemlos.

Benutzeravatar
wschrewe
Fachberater
Beiträge: 325
Registriert: Dienstag 25. September 2018, 17:36
Schulform: BK (Pensionär)
Kontaktdaten:

Re: Fehler (?) mit .lck-Dateien und Formularexplorer

Beitrag von wschrewe » Sonntag 12. Januar 2020, 11:09

NielsWestphal hat geschrieben:
Samstag 11. Januar 2020, 16:28
Ich schon.
Meine Antwort bezog sich auf den Klausur-XML-Import. Den Umgang mit den Lockdateien werde ich noch mal überdenken. Wie groß ist denn bei Ihnen die (praktische) Wahrscheinlichkeit, dass mehrere Benutzer auf die gleiche Datei zugreifen?
Mit freundlichen Grüßen
Walter Schrewe
"If all else fails, read the instructions" (Donald E. Knuth, letzter TeX - Hilfehinweis)

NielsWestphal
Beiträge: 233
Registriert: Sonntag 2. Dezember 2018, 18:33
Schulform: Gymnasium

Re: Fehler (?) mit .lck-Dateien und Formularexplorer

Beitrag von NielsWestphal » Sonntag 12. Januar 2020, 11:45

Unterschiedliche Personen haben unterschiedliche Aufgaben: Noten, Klausurplanung, LuPO Import. Und nicht nur bei uns kommt es ja vor, wenn auch nicht absichtlich, dass jemand die Blockung offen hat und vergisst zu schließen, danach aber jemand anderes zugreift.
Vorher ging es ja und die lck-Datei fast ein mehrfaches öffnen verhindert.
mfg
Niels Westphal

Benutzeravatar
wschrewe
Fachberater
Beiträge: 325
Registriert: Dienstag 25. September 2018, 17:36
Schulform: BK (Pensionär)
Kontaktdaten:

Re: Fehler (?) mit .lck-Dateien und Formularexplorer

Beitrag von wschrewe » Sonntag 12. Januar 2020, 11:55

Die Lockdatei wird jetzt gelöscht, wenn der Eigentümer die Blockungsdatei schließt, weil er eine andere Datei öffnet oder das Programm bei geöffneter Blockung beendet. Damit sollte das Problem beseitigt sein.
Mit freundlichen Grüßen
Walter Schrewe
"If all else fails, read the instructions" (Donald E. Knuth, letzter TeX - Hilfehinweis)

NielsWestphal
Beiträge: 233
Registriert: Sonntag 2. Dezember 2018, 18:33
Schulform: Gymnasium

Re: Fehler (?) mit .lck-Dateien und Formularexplorer

Beitrag von NielsWestphal » Sonntag 12. Januar 2020, 11:56

Sehr gut!
mfg
Niels Westphal

Benutzeravatar
wschrewe
Fachberater
Beiträge: 325
Registriert: Dienstag 25. September 2018, 17:36
Schulform: BK (Pensionär)
Kontaktdaten:

Re: Fehler (?) mit .lck-Dateien und Formularexplorer

Beitrag von wschrewe » Sonntag 12. Januar 2020, 12:01

dkohle hat geschrieben:
Samstag 11. Januar 2020, 21:08
Ich sollte präzisieren: Ich kann die Klausurreports nach dem XML-Import nicht starten. Es kommt eine Fehlermeldung. Nach einem Neustart von Kurs geht alles problemlos.
Auch das konnte ich (mit meinen Daten) nicht nachvollziehen. Können Sie mir die Blockung und die XML-Datei mal zuschicken?
Mit freundlichen Grüßen
Walter Schrewe
"If all else fails, read the instructions" (Donald E. Knuth, letzter TeX - Hilfehinweis)

dkohle
Beiträge: 22
Registriert: Donnerstag 10. Januar 2019, 12:25
Schulform: Gymnasium

Re: Fehler (?) mit .lck-Dateien und Formularexplorer

Beitrag von dkohle » Donnerstag 16. Januar 2020, 18:39

wschrewe hat geschrieben:
Sonntag 12. Januar 2020, 12:01
dkohle hat geschrieben:
Samstag 11. Januar 2020, 21:08
Ich sollte präzisieren: Ich kann die Klausurreports nach dem XML-Import nicht starten. Es kommt eine Fehlermeldung. Nach einem Neustart von Kurs geht alles problemlos.
Auch das konnte ich (mit meinen Daten) nicht nachvollziehen. Können Sie mir die Blockung und die XML-Datei mal zuschicken?
Habe es eben geschickt. Vielen Dank für die Prüfung!

Antworten

Zurück zu „Allgemeines“