SMTP-Versand aus Lupo

Informationen, Tipps (und Fragen) zum Beratungsprogramm für die gymnasiale Oberstufe

Moderator: Raffenberg

Benutzeravatar
Koch
Fachberater*in
Beiträge: 67
Registriert: Donnerstag 11. Oktober 2018, 17:49
Schulform: Gymnasium

SMTP-Versand aus Lupo

Beitrag von Koch »

Guten Tag,
beim Versuch Lupo-Schülerdatein direkt aus Lupo zu versenden (Version 2.1.4.5) erhalten wir einen Timeout und einen Hinweis auf den SMTP-Port 25, den wir aber nicht angegeben haben. (siehe Fehlermeldung). Wir haben die lokale Firewall testweise schon mal ausgeschaltet, ohne Erfolg. Was können wir noch tun?
Grüße
DK



ChilkatLog:
SendEmail:
DllDate: Dec 21 2018
ChilkatVersion: 9.5.0.76
UnlockPrefix: RIBEKA.CB4072020
Architecture: Little Endian; 32-bit
VerboseLogging: 0
Component successfully unlocked using purchased unlock code.
sendEmailInner:
renderToMime_pt1:
createEmailForSending:
Auto-generating Message-ID
--createEmailForSending
--renderToMime_pt1
sendMimeInner:
ensureSmtpSession:
ensureSmtpConnection:
smtpParams:
SmtpHost: smtp.office365.com
SmtpPort: 25
SmtpUsername: XXXXXXX@gymstopp.org
SmtpSsl: 0
StartTLS: 1
--smtpParams
smtpConnect:
smtpHostname: smtp.office365.com
smtpPort: 25
connectionIsReady:
Need new SMTP connection
--connectionIsReady
smtpSocketConnect:
socket2Connect:
connect2:
connectSocket:
connect_ipv6_or_ipv4:
Connection attempt failed.
maxWaitTimeMs: 30000
The Windows TCP/IP stack has a system wide retry delay and retry count for the initial connection.
The default settings result in an overall 21 second timeout.
If you see this error message 21 seconds after the connection attempt is initiated, it usually means one of two things:
(1) The server is not there (not listening for connection attempts on the specified IP address and port).
(2) A firewall is blocking your connection attempt from reaching the server.
totalMsWaitedSoFar: 20800
--connect_ipv6_or_ipv4
--connectSocket
ConnectFailReason: Connection rejected
A few possible causes for a connection being rejected are:
- A firewall (software or hardware), such as Windows Firewall, is blocking the connection .
- Nothing is listening at the remote host:port
--connect2
--socket2Connect
Failed to connect to SMTP server..
--smtpSocketConnect
--smtpConnect
--ensureSmtpConnection
--ensureSmtpSession
--sendMimeInner
--sendEmailInner
Failed.
--SendEmail
--ChilkatLog
Benutzeravatar
Pfotenhauer
Beiträge: 2443
Registriert: Dienstag 25. September 2018, 12:53
Wohnort: Wuppertal
Schulform: Realschule
Motto: Wer schnell hilft, hilft doppelt!
Kontaktdaten:

Re: SMTP-Versand aus Lupo

Beitrag von Pfotenhauer »

The Windows TCP/IP stack has a system wide retry delay and retry count for the initial connection.
The default settings result in an overall 21 second timeout.
If you see this error message 21 seconds after the connection attempt is initiated, it usually means one of two things:
(1) The server is not there (not listening for connection attempts on the specified IP address and port).
(2) A firewall is blocking your connection attempt from reaching the server.
totalMsWaitedSoFar: 20800
--connect_ipv6_or_ipv4
--connectSocket
ConnectFailReason: Connection rejected
A few possible causes for a connection being rejected are:
- A firewall (software or hardware), such as Windows Firewall, is blocking the connection .
- Nothing is listening at the remote host:port


Und da steht:
Failed to connect to SMTP server..
Mit freundlichen Grüßen
Frank Pfotenhauer
--------------------------------------------------------------------
Fachberater für die Schulverwaltungssoftware des MSB
Referat 133
Fon: 0202-2984640
E-Mail: pfotenhauer@schildnrw.de
Benutzeravatar
Koch
Fachberater*in
Beiträge: 67
Registriert: Donnerstag 11. Oktober 2018, 17:49
Schulform: Gymnasium

Re: SMTP-Versand aus Lupo

Beitrag von Koch »

Die Frage, die aber bleibt ist wieso? In der Fehlermeldung steht nämlich auch, dass der SMTP-Port 25 benutzt wurde, korrekt (und in Lupo eingegeben) ist 587.
Das selbe Problem stellt sich auch übrigens auch in Schild.
Grüße
Daniel
Benutzeravatar
Pfotenhauer
Beiträge: 2443
Registriert: Dienstag 25. September 2018, 12:53
Wohnort: Wuppertal
Schulform: Realschule
Motto: Wer schnell hilft, hilft doppelt!
Kontaktdaten:

Re: SMTP-Versand aus Lupo

Beitrag von Pfotenhauer »

Hallo.

Probieren Sie doch mal 25...
Mit freundlichen Grüßen
Frank Pfotenhauer
--------------------------------------------------------------------
Fachberater für die Schulverwaltungssoftware des MSB
Referat 133
Fon: 0202-2984640
E-Mail: pfotenhauer@schildnrw.de
Benutzeravatar
Koch
Fachberater*in
Beiträge: 67
Registriert: Donnerstag 11. Oktober 2018, 17:49
Schulform: Gymnasium

Re: SMTP-Versand aus Lupo

Beitrag von Koch »

Funktioniert leider nicht, der SMTP-Server verlangt laut Provider auch Port 587. Mich wundert nur, dass in der Fehlermeldung 25 auftaucht, obwohl 587 eingestellt ist. Dies wies für mich auf ein Problem bei der Übernahme der Einstellungen beim Fleximailer (über den die Mails doch versendet werden sollen) hin.
Benutzeravatar
Raffenberg
Fachberater*in
Beiträge: 689
Registriert: Dienstag 25. September 2018, 15:22
Schulform: Gymnasium

Re: SMTP-Versand aus Lupo

Beitrag von Raffenberg »

Benutzt Office 365 nicht SSL. Es sieht aus, als würdest Du TSL aktiviert haben.
Mit freundlichen Grüßen
Jens Raffenberg
Benutzeravatar
Koch
Fachberater*in
Beiträge: 67
Registriert: Donnerstag 11. Oktober 2018, 17:49
Schulform: Gymnasium

Re: SMTP-Versand aus Lupo

Beitrag von Koch »

Versuche es mal mit SSL (ich glaube das habe ich auch schon, aber sicher ist sicher...morgen...in der Schule).
Danke, Daniel
Benutzeravatar
Pfotenhauer
Beiträge: 2443
Registriert: Dienstag 25. September 2018, 12:53
Wohnort: Wuppertal
Schulform: Realschule
Motto: Wer schnell hilft, hilft doppelt!
Kontaktdaten:

Re: SMTP-Versand aus Lupo

Beitrag von Pfotenhauer »

Hallo.

In Lupo werden wir das kontrollieren.
In Schild-NRW klappt es bei mir mit Port 587 einwandfrei...
Mit freundlichen Grüßen
Frank Pfotenhauer
--------------------------------------------------------------------
Fachberater für die Schulverwaltungssoftware des MSB
Referat 133
Fon: 0202-2984640
E-Mail: pfotenhauer@schildnrw.de
Stefan Scheidt
Beiträge: 2
Registriert: Mittwoch 22. April 2020, 09:00
Schulform: Schulträger

Re: SMTP-Versand aus Lupo

Beitrag von Stefan Scheidt »

Hallo zusammen!

Ich kann das Verhalten mit dem Ignorieren des eingestellten Ports bei beiden Programmen bestätigen.

Wenn ich lokal einen Fake-SMTP-Server auf Port 25 und einen weiteren auf Port 587 starte und dann in den SMTP-Einstellungen Port 587 angebe, werden Mails von beiden Programmen nur auf dem Server auf Port 25 eingeliefert. Schalte ich diesen ab, kommt die von Daniel Koch gepostete Fehlermeldung mit dem Verweis auf Port 25.

Des Weiteren ignoriert Schild auch noch die Einstellung zu StartTLS. Im Log steht dort grundsätzlich nur "StartTLS=0" und es wird auch keine Verschlüsselung gestartet.

Grüße aus dem sonnigen Münsterland
Stefan Scheidt
Mit freundlichen Grüßen

Stefan Scheidt
Benutzeravatar
Pfotenhauer
Beiträge: 2443
Registriert: Dienstag 25. September 2018, 12:53
Wohnort: Wuppertal
Schulform: Realschule
Motto: Wer schnell hilft, hilft doppelt!
Kontaktdaten:

Re: SMTP-Versand aus Lupo

Beitrag von Pfotenhauer »

Hallo.

Können Sie bitte auch mal die Snapshotversion testen?

https://www.svws.nrw.de/download/beta-versionen

Dort ist eine angepasste Chilkat.dll im Zip.
Die bitte mal für LuPO benutzen.
Mit freundlichen Grüßen
Frank Pfotenhauer
--------------------------------------------------------------------
Fachberater für die Schulverwaltungssoftware des MSB
Referat 133
Fon: 0202-2984640
E-Mail: pfotenhauer@schildnrw.de
Antworten

Zurück zu „Laufbahn und Planungstool“