Zugriffsverletzung beim Ersellen einer neuen Kursblockung

Spezielle Fragen zum Import/Export von Kurs42 nach Schild-NRW

Moderator: wschrewe

Kerstin Knapp
Beiträge: 12
Registriert: Montag 10. Dezember 2018, 11:30
Schulform: Gesamtschule

Re: Zugriffsverletzung beim Ersellen einer neuen Kursblockung

Beitrag von Kerstin Knapp »

Hallo Herr Schrewe,

vielen Dank für Ihre schnelle Antwort.

Wir haben nun nach Einspielen der dll immer noch denselben Fehler. Auch der Start im debug-Modus bringt vermutlich keine neuen Erkenntnisse:
Die letzte Meldung bezog sich auf die erfolgreiche Verbindung mit der DB.
Nach Klick auf "Blockung anlegen" kommt die bekannte Fehlermeldung u. keine weitere Debug-Meldung.
Wenn ich die Fehlermeldung wegklicke, ist das Programm eingefroren und ich bekomme keine Rückmeldung.

Mit freundlichen Grüßen
Kerstin Knapp
Herzlichen Dank im Voraus
Kerstin Knapp
Benutzeravatar
wschrewe
Fachberater*in
Beiträge: 1013
Registriert: Dienstag 25. September 2018, 17:36
Schulform: BK (Pensionär)
Kontaktdaten:

Re: Zugriffsverletzung beim Ersellen einer neuen Kursblockung

Beitrag von wschrewe »

Kerstin Knapp hat geschrieben: Donnerstag 17. Juni 2021, 10:35Nach Klick auf "Blockung anlegen" kommt die bekannte Fehlermeldung u. keine weitere Debug-Meldung.
Ich habe gerade einen neuen Snapshot hochgeladen, der im Debug-Modus noch ausführlicher ist und jeden Schritt, nachdem "Blockung anlegen" angeklickt wurde, dokumentiert. Damit sollte sich eingrenzen lassen, wo der Fehler auftritt.
Mit freundlichen Grüßen
Walter Schrewe
"If all else fails, read the instructions" (Donald E. Knuth, letzter TeX - Hilfehinweis)
Kerstin Knapp
Beiträge: 12
Registriert: Montag 10. Dezember 2018, 11:30
Schulform: Gesamtschule

Re: Zugriffsverletzung beim Ersellen einer neuen Kursblockung

Beitrag von Kerstin Knapp »

Hallo,

vielen Dank für den Snapshot, den ich jetzt in der Version eingefügt habe.
Anhängend sende ich die Fehlermeldung mit.

Schöne Grüße
Kerstin Knapp
Dateianhänge
Fehlermeldung_nachSnapshot.jpg
Fehlermeldung_nachSnapshot.jpg (428.33 KiB) 134 mal betrachtet
Herzlichen Dank im Voraus
Kerstin Knapp
Benutzeravatar
wschrewe
Fachberater*in
Beiträge: 1013
Registriert: Dienstag 25. September 2018, 17:36
Schulform: BK (Pensionär)
Kontaktdaten:

Re: Zugriffsverletzung beim Ersellen einer neuen Kursblockung

Beitrag von wschrewe »

Kerstin Knapp hat geschrieben: Donnerstag 17. Juni 2021, 13:40Anhängend sende ich die Fehlermeldung mit.
Danke dafür. Eigentlich müssten nach dem Klick auf "Blockung anlegen" eine Folge von Messageboxen erscheinen, die sagen, was als nächstes ausgeführt wird. Ist das nicht geschehen? Wenn ja, was war die letzte Meldung vor dem Absturz?

Merkwürdig ist, dass die ausgeworfene Fehlermeldung auf Speicherlecks in der Report-Komponente hindeutet, die in dieser Situation überhaupt nicht aktiv ist.
Mit freundlichen Grüßen
Walter Schrewe
"If all else fails, read the instructions" (Donald E. Knuth, letzter TeX - Hilfehinweis)
Kerstin Knapp
Beiträge: 12
Registriert: Montag 10. Dezember 2018, 11:30
Schulform: Gesamtschule

Re: Zugriffsverletzung beim Ersellen einer neuen Kursblockung

Beitrag von Kerstin Knapp »

Nee, es ist keine Messagebox erschienen, keine Meldung, nur sofort die Fehlermeldung, die ich angehängt hatte.
Herzlichen Dank im Voraus
Kerstin Knapp
Benutzeravatar
wschrewe
Fachberater*in
Beiträge: 1013
Registriert: Dienstag 25. September 2018, 17:36
Schulform: BK (Pensionär)
Kontaktdaten:

Re: Zugriffsverletzung beim Ersellen einer neuen Kursblockung

Beitrag von wschrewe »

Die Messageboxen kommen auch nur beim aktuellen Snapshot mit Parameter -DEBUG:
Mit freundlichen Grüßen
Walter Schrewe
"If all else fails, read the instructions" (Donald E. Knuth, letzter TeX - Hilfehinweis)
Benutzeravatar
wschrewe
Fachberater*in
Beiträge: 1013
Registriert: Dienstag 25. September 2018, 17:36
Schulform: BK (Pensionär)
Kontaktdaten:

Re: Zugriffsverletzung beim Ersellen einer neuen Kursblockung

Beitrag von wschrewe »

Ich habe noch etwas nachgeforscht. Aus den Fehlermeldungen kristallisiert sich heraus, dass der Fehler offenbar auftritt, wenn eine Abfrage (SELECT US_PasswordHash,US_LoginName,US_Privileges FROM Users WHERE SchulnrEigner=123456) auf 'die Tabelle 'Users' geöffnet wird. Das funktioniert bei mir (getestet mit Access, NySQL, SQL-Server) und auch bei vielen anderen problemlos. Es wäre interessant zu wissen, ob dieser Fehler nur bei SchildZentral.Installationen, d.h. MS-SQLServer) oder auch bei lokalen (Netzwerk) Installationen, z.B. mit Access, auftritt.
Mit freundlichen Grüßen
Walter Schrewe
"If all else fails, read the instructions" (Donald E. Knuth, letzter TeX - Hilfehinweis)
Kerstin Knapp
Beiträge: 12
Registriert: Montag 10. Dezember 2018, 11:30
Schulform: Gesamtschule

Re: Zugriffsverletzung beim Ersellen einer neuen Kursblockung

Beitrag von Kerstin Knapp »

So, nun habe ich Kurs mit dem Parameter DEBUG geöffnet.
Nach Klick auf "Blockung anlegen": Blockung wird angelegt -> Blockung wird erzeugt-> Beginn der Initalisierung-> Laden: Kursarten-> Kursarten geladen:22-> Laden: Fächertabelle-OK dann erscheint die Fehlermeldung:
Zugriffsverletzung bei Adresse 004078B7 in Modul "kurs32.exe" Lesen von adresse 0776004A -> Ok-> Fächer geladen: 0->Laden:Lehrertabelle-> OK
dann 'keine Rückmeldung' vom Programm.
Dateianhänge
Fehlermeldung_Kurs42Blockung2.jpg
Fehlermeldung_Kurs42Blockung2.jpg (182.46 KiB) 92 mal betrachtet
Herzlichen Dank im Voraus
Kerstin Knapp
jschaldach
Beiträge: 5
Registriert: Dienstag 22. Juni 2021, 18:31
Schulform: Gymnasium

Re: Zugriffsverletzung beim Ersellen einer neuen Kursblockung

Beitrag von jschaldach »

Hallo Herr Schrewe und Mitleser/innen,

leider ist das Problem der Erstellung einer neuen Blockungsdatei bei Verbindung mit einer Schild-DB auf einem Linux-Server (MySQL) offenbar noch nicht gelöst:

Ich habe hier heute viel probiert, wobei ich mich an den Hinweisen hier im Forum orientiert habe. Die Nutzung der Snapshot-Version vom 17.6. hat nichts genützt. Im Debug-Modus wurde nur deutlich, dass die UDL-Datei offenbar gefunden wird und der Login in die DB funktioniert, aber danach war dann Schluss.

Letztlich blieb das Programm entweder komplett hängen, oder es gab Zugriffsfehler und Neustart der Anwendung. Selten kam tatsächlich das Fenster zum Anlegen der Blockung, und da war dann folgendes interessant: Als Schuljahre wurde mir ein Bereich von 1995/96 (?) bis 2000/01 angeboten, und es gab rechts keine Auswahl des Jahrgangs: Offenbar werden also bestimmte benötigte Daten nicht gefunden. Weiter ging es dann nicht mehr.

Mein Workaround war dann die Erstellung einer Access-DB mit Hilfe des Migrationstools; die Erstellung der Blockungsdatei über meine access.udl klappte dann auf Anhieb (mit Import aus LuPO). Mit der fertigen Blockungsdatei funktioniert dann die Verbindung zur MySQL-DB wieder ganz normal
(z.B. Schüler mit DB-Zugriff bearbeiten.)

Unsere neue EF-Kurs-Datei ist ja nun fertig, aber es wäre natürlich schön, wenn sich das Problem komplett lösen ließe. Wenn ich dazu noch etwas besteuern kann, gerne.

Ansonsten vielen Dank für die Arbeit an dem Tool.

Freundliche Grüße,
Jörg Schaldach
jschaldach
Beiträge: 5
Registriert: Dienstag 22. Juni 2021, 18:31
Schulform: Gymnasium

Re: Zugriffsverletzung beim Ersellen einer neuen Kursblockung

Beitrag von jschaldach »

Nachtrag:
Die im Post von Montag zitierte Abfrage (SELECT US_PasswordHash,US_LoginName,US_Privileges FROM Users WHERE SchulnrEigner=123456) funktioniert bei unserer MariaDB problemlos (und liefert die gewünschten Angaben bei passender Schulnummer) - jedenfalls, wenn ich sie direkt per mysql-cli auf dem Linux-Server absetze. Ich denke, dass der Login klappt, aber dann bestimmte Daten, die zur Erzeugung einer neuen Blockungsdatei nötig wären, nicht gefunden werden (wegen Groß/Kleinschreibung, Zeichensatz o.ä.).

Viele Grüße,
Jörg Schaldach
Antworten

Zurück zu „Import/Export“