Seite 1 von 1

Fehler im Formular

Verfasst: Sonntag 29. Dezember 2019, 09:33
von j.neubauer
Hallo liebe Leserinnen und Leser,

ich habe ein Formular erstellt für die Mitteilung von Ordnungsmaßnahmen. Durch die Hilfe eines Kollegen konnte ich Checkboxen verwenden.
Nun mein Problem.

Die Checkboxen 3 und 8 kann ich beim Start auswählen, werden aber in der Druckvorschau und beim Drucken nicht mit einem Haken versehen.
Jetzt habe ich schon Stunden die Berechnungen verglichen und finde den Fehler nicht. Ich habe auch schon die Checkboxen gelöscht und neu hinzugefügt. Einzelne gelöscht und wieder hinzugefügt. Alles ohne Erfolg.

Ich bitte wenn möglich um Unterstützung. Ich hoffe sehr, dass jemand den Fehler findet und mir auf dei Sprünge hilft. Unten das Formular

Vielen Dank im Vorraus und allen einen guten Rutsch ins neue Jahr, Gesundheit und Erfolg.

Jörg Neubauer
Ordnungsmassnahme Mitteilung.rtm
Fehlerhaft Box 3 und 8
(21.06 KiB) 23-mal heruntergeladen

Re: Fehler im Formular

Verfasst: Sonntag 29. Dezember 2019, 12:43
von wschrewe
j.neubauer hat geschrieben: Sonntag 29. Dezember 2019, 09:33Ich hoffe sehr, dass jemand den Fehler findet und mir auf dei Sprünge hilft.
Der Fehler liegt in den Texten zu Option 3 und 8, die am Ende unnötige Leerzeichen enthalten. Anscheinend führt die Funktion Pos(..) intern ein Trim durch, bevor sie vergleicht. Wenn man die Leerzeichen beseitigt, funktioniert das Formular wie gewünscht. Ich habe mir erlaubt, den Code in DetailBeforePrint etwas zu vereinfachen und zu kommentieren. Das geänderte Formular habe ich angehängt.

Re: Fehler im Formular

Verfasst: Sonntag 29. Dezember 2019, 13:51
von j.neubauer
Vielen Dank für die schnelle Antwort und die Korrektur.

Liebe Grüße und ein gutes gesundes neues Jahr.

Jörg Neubauer